Dagelijks archief: april 1, 2006

De eerste screencasts zijn er…

Na veel Camtasia ellende heb ik dan toch uiteindelijk de eerste twee screencasts gemaakt van een serie van 5 tot 10 over videometen in het COMPEX Natuurkunde examen.

Ik heb gekozen voor korte screencast die telkens ingaat op een specifieke vaardigheid zoals gespecificeerd door het CITO (of beter gezegd een combinatie van gerelateerde vaardigheden). Verder probeer ik niet te perfectionistisch te zijn, maar in 2 of 3 pogingen een acceptabel filmpje op te nemen en de foutjes hier en daar voor lief te nemen.

Hoe dat er dan voor leerlingen uitziet is hier te zien.

Ik hoop de komende 2 a 3 dagen nog een aantal filmpjes te kunnen maken, want ik ga ze vanaf dinsdag in de klas gebruiken. Ik rapporteer natuurlijk over de resultaten!

Advertenties

Camtasia audio bug (opgelost)

Ik ben druk bezig met het maken van een aantal screencast over Videometen in het kader van het COMPEX (Computer examen) Natuurkunde 1,2.

Het lukt inmiddels aardig, maar ik loop tegen een vervelende Camtasia/Flash bug aan, waar Hans Mestrum vorig jaar september al over schreef; De laatste 10 tot 30 seconden audio van een screencast verdwijnen tijdens het produceren van de Flash film. De screencast heeft in Camtasia gewoon audio tot het eind, maar in het Flash filmpje stopt de audio abrupt in de laatste 30 seconden. Ik heb als tussenoplossing maar een stukje tekst aan het einde van het filmpje toegevoegd (credits). In plaats van 5 seconden laat ik deze tekst 40 seconden staan. Het werkt, maar het is geen pretje…

Ik gebruik de laatste versies van zowel Camtasia als de Flash player.

Erg irritant!

Edit: De bug is nu opgelost, maar het heeft me ruim 2 uur puzzelen gekost…

Het blijkt geen Camtasia bug, maar een Codec probleem. Specifiek in de Frauenhofer MP3 codec die bij Windows Mediaplayer 10 geleverd wordt.

De oplossing:

Ga naar Configuratiescherm > Geluid > Hardware > Audio Codecs > Eigenschappen. Als Frauenhofer IIS MP3 codec de (Professional) versie is dan zit het probleem in deze codec.

Ga naar C:\Windows\System32 en zoek het bestand l3codeca.acm. Dit is de juiste versie van de Frauenhofer MP3 codec. Kijk in Eigenschappen > Versie van dit bestand, het controleer dat het versie 1.9.x.x is. Als alleen l3codecp.acm te vinden in (versie 3.3.0.44) dan is alleen de professional versie geinstalleerd. Installeer dan de oude codec door Windows Media Encoder 7.1 (NIET 9.0) te installeren. Deze is te vinden op: ftp://customer:support@supportftp.techsmith.com/wmencoder71.exe

Tot zover geen probleem, maar ik kreeg na het installeren van de codec uit Windows Media Encoder geen enkel geluid meer uit Flash filmpjes van Camtasia. Op de een of andere manier gebruikte Camtasia niet de juiste codec voor het coderen van de MP3 audio. PCM audio werkte wel gewoon. Camtasia opnieuw installeren had geen resultaat.

Uiteindelijk heb de l3codeca.acm handmatig via in het registry geregistreerd, d.m.v. het volgende registry script. (via Chris Lanier’s Blog):

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32]
“msacm.l3acm”=”l3codeca.acm”
“msacm.l3codec”=”l3codeca.acm”

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\drivers.desc]
“l3codecp.acm”=”Fraunhofer IIS MPEG Layer-3 Codec (professional)”

Plak het script in notepad, noem het l3codec.reg en voer het uit. Merk op dat de beschrijving van deze codec (professional) niet klopt, dit moet (advanced) zijn. Ik heb niet uitgeprobeerd of dit uitmaakt en/of noodzakelijk is voor het goed functioneren van Camtasia.